Technical Requirements

To successfully use the Revive Adserver REST API software, we recommend always using the most recent version of the core Revive Adserver software.

We have successfully tested the Revive Adserver REST API software with all versions of Revive Adserver v4.x and v5.0.x.

The use of the Revive Adserver REST API with older versions of the core Revive Adserver may be possible, but can not be guaranteed.

The technical requirements to run Revive Adserver are outlined on their website. If your server hardware and software meet these technical requirements to run Revive Adserver itself, the Revive Adserver REST API should also work correctly.

The most recent version of the Revive Adserver software is always available for download free of charge from their website. Please also consult their instructions for installation or upgrading.

We want to explicitly mention that as of v4.0 of the Revive Adserver REST API, we no longer support the by-now completely out of date v5.3 of the PHP software.

Specific information regarding Hourly statistics

Starting with Revive Adserver REST API version 4.4.0, released on October 22, 2018, the REST API supports retrieving statistics broken down by hour.

This requires some associated enhancements in the core Revive Adserver software as well. These enhancements, which have been developed by the Revive Adserver REST API team, have been contributed to the core Revive Adserver software, and have been incorporated in version 4.2.0 of the Revive Adserver software, which has been released on April 23, 2019.

This page was last updated September 30, 2019

Current version

The most recently released version of the Revive Adserver REST API is v5.0.0 (publication date February 20, 2019).

See Release Notes

Compatibility

Revive Adserver REST API is compatible with all versions of Revive Adserver v4.x and v5.0. It may also be compatible with Revive Adserver v3.x (and also with OpenX Source v2.8 and higher), but this can not be guaranteed.

Revive Adserver REST API is compatible with all supported versions of PHP, including PHP7.

Also see Technical Requirements, Product Content, and Installation Instructions.

Our Recent Tweets